Cisco configurations

Cisco IOS config for KPN ADSL

This configuration shows a PPPoA setup for the Dutch ISP KPN (Planet Internet, Het Net, XS4ALL, etc). See also Yabu.

Prerequisites:

  • IOS 12.x or higher
  • Cisco xDSL router (SOHO,8xx,17xx,18xx,26xx,28xx,36xx,37xx,38xx)


    IOS Configuration

    !
    service password-encryption
    !
    hostname user-adsl-planet
    !
    logging rate-limit console 10 except errors
    enable secret 
    !
    ip subnet-zero
    no ip finger
    ip name-server 195.121.1.34 195.121.1.66
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool CLIENT
       import all
       network 10.10.10.0 255.255.255.0
       dns-server 195.121.1.34 195.121.1.66
       default-router 10.10.10.1
    !
    !
    interface Ethernet0
     ip address 10.10.10.1 255.255.255.0
     ip nat inside
     no shut
    !
    interface ATM0
     no shut
     no ip address
     load-interval 30
     no atm ilmi-keepalive
     pvc 8/48
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
     bundle-enable
     hold-queue 224 in
    !
    interface Dialer0
     ip address negotiated
     ip nat outside
     encapsulation ppp
     dialer pool 1
     dialer-group 1
     no cdp enable
     ppp pap sent-username @adsl-advanced password 
    
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    !
    ip nat inside source list 101 interface Dialer0 overload
    access-list 101 permit ip 10.10.10.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    !
    !
    line con 0
     exec-timeout 120 0
     transport input none
     stopbits 1
    line vty 0 4
     exec-timeout 0 0
     password 
     login local
     length 0
    !