Cisco configurations

Cisco IOS config for BBned ADSL

This configuration shows an RFC1483 setup for the Dutch ISP bbned (BBeyond, Demon, etc). See also Yabu.

Prerequisites:

  • IOS 12.x or higher
  • Cisco xDSL router (SOHO,8xx,17xx,18xx,26xx,28xx,36xx,37xx,38xx)


    !
    no service pad
    service password-encryption
    !
    hostname bbned-adsl
    !
    enable secret 
    !
    ip subnet-zero
    no ip source-route
    ip domain name bbned.nl
    ip name-server 62.177.144.11
    ip name-server 82.204.127.40
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool 10.10.10.0/24
       import all
       network 10.10.10.0 255.255.255.0
       default-router 10.10.10.1
       domain-name bbned.nl
       netbios-node-type h-node
       dns-server 62.177.144.11 82.204.127.40
    !
    no ip bootp server
    ip cef
    !
    bridge irb
    !
    !
    interface Null0
     no ip unreachables
    !
    interface Ethernet0
     ip address 10.10.10.1 255.255.255.0
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat inside
     no cdp enable
    !
    interface ATM0
     no ip address
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat outside
     no atm ilmi-keepalive
     dsl operating-mode auto
     bridge-group 1
     pvc 0/35
      no broadcast
      encapsulation aal5snap
      no protocol ip inarp
     !
    !
    interface BVI1
     ip address dhcp
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat outside
    !
    ip classless
    no ip http server
    no ip http secure-server
    ip nat inside source list NAT interface BVI1 overload
    !
    ip access-list extended NAT
     permit ip 10.10.10.0 0.0.0.255 any
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
     no modem enable
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     password 
     login
    !
    end